Demo compile errors

Demo compile errors

Postby monark » Wed Sep 14, 2011 3:26 pm

Hi new to the forum,
Just trying to look at the demo files that come with the latest EZ Gui package and when I load them I get compile errors and can't run them.

E.g
EZ GUI, Simple Demo

Assets/Plugins/EZ/GUI/Controls/UIVirtualScreen.cs(25,47): error CS0246: The type or namespace name `IUIObject' could not be found. Are you missing a using directive or an assembly reference?

Assets/Plugins/EZ/GUI/Support/IPackableControl.cs(12,54): error CS0246: The type or namespace name `IControl' could not be found. Are you missing a using directive or an assembly reference?
monark
 
Posts: 10
Joined: Wed Sep 14, 2011 3:20 pm

Re: Demo compile errors

Postby monark » Wed Sep 14, 2011 4:01 pm

Completely deleted all EZ Gui assets and re-imported now I get a new error

Assets/Plugins/Sprite Scripts/Support/ISpriteMesh.cs(19,29): error CS0106: The modifier `abstract' is not valid for this item
monark
 
Posts: 10
Joined: Wed Sep 14, 2011 3:20 pm

Re: Demo compile errors

Postby Brady » Thu Sep 15, 2011 12:54 am

Sounds like something strange. Are you sure you're using both the latest EZ GUI (1.07) as well as the latest demo package? There was a demo package a little while ago that accidentally included some EZ GUI core library files, which would then overwrite the newer ones from the core package.
Brady
 
Posts: 5361
Joined: Tue Jul 06, 2010 11:33 pm

Re: Demo compile errors

Postby monark » Thu Sep 15, 2011 8:35 am

Well I just used the asset store to download and import and then installed the demo scenes direct from the installed assets demo directory.
monark
 
Posts: 10
Joined: Wed Sep 14, 2011 3:20 pm

Re: Demo compile errors

Postby monark » Thu Sep 15, 2011 8:51 am

Looking at this some more I think the error you describe is what is causing this, I'm now getting errors saying scripts exist in multiple locations. Has the asset store got the latest demos? I can't download from your website as I don't have an activation code.
monark
 
Posts: 10
Joined: Wed Sep 14, 2011 3:20 pm

Re: Demo compile errors

Postby monark » Thu Sep 15, 2011 9:08 am

ok got it working. Started from scratch and re-imported again having quit Unity first. Then it worked ok with the latest version from the asset store. I think something was messed up from the the first install that unity was hanging onto even though I deleted everything. The only other issue was having to install Cheetah 3d.
monark
 
Posts: 10
Joined: Wed Sep 14, 2011 3:20 pm

Re: Demo compile errors

Postby monark » Thu Sep 15, 2011 9:50 am

EZ GUI Demo, Simple is still giving this error though

Assets/Plugins/Sprite Scripts/Support/ISpriteMesh.cs(19,29): error CS0106: The modifier `abstract' is not valid for this item

Castle Storm, Earth, FPS Hangar, Mushroom and wizard from script are ok
monark
 
Posts: 10
Joined: Wed Sep 14, 2011 3:20 pm

Re: Demo compile errors

Postby monark » Thu Sep 15, 2011 9:57 am

One final thing.. MathUtils exists in 2 demos and so throws an error if you import both into one Unity project.
monark
 
Posts: 10
Joined: Wed Sep 14, 2011 3:20 pm

Re: Demo compile errors

Postby Brady » Thu Sep 15, 2011 5:44 pm

Ahh, it looks like somehow an old version of the simple demo package got included in the Asset Store. I'll submit an update.
Brady
 
Posts: 5361
Joined: Tue Jul 06, 2010 11:33 pm

Re: Demo compile errors

Postby chaneya » Thu Sep 22, 2011 4:58 pm

Brady,

Since it appears it's going to take several weeks for the Asset Store to update with the correct build of the EZ GUI Demo, Simple. Can you just tell me what code I need to change to get it working.
It has something to do with the term abstract.

Thanks
Allan
chaneya
 
Posts: 3
Joined: Tue Jun 14, 2011 4:06 pm

Next

Return to EZ GUI General

Who is online

Users browsing this forum: Google [Bot] and 5 guests